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Quick Start Guide 
 
The following steps will allow you to install and quickly begin using DevCom2000. This quick start guide is for 
experienced HART users, full instructions are provided later in this manual for non-experienced users. 
 

Step 1: Install the DevCom2000 application 
Either using the DevCom2000 installation CD, or the downloaded installation files, install DevCom2000 in its default 
location.  If using the CD and the installation program does not begin automatically, please double click on 
“DevCom2000Setup.exe” on the CD. This will begin the installation program. 
 

Step 2: Connect the HART Modem to your PC 
Connecting to a wired (4-20mA) HART device requires a HART interface (called a HART Modem) to be connected to 
your computer, DevCom2000 will work with all HART Modems. There are three types of HART Modem; RS232 
(Serial), USB and Bluetooth, all of which are available from HART Expert Ltd. Connect your HART modem to your PC. 
Make a note of the Serial port (COM port) number that your HART Modem is using, if you do not know, please refer 
to the HART Modem manufacturers literature on how to find out. Later (in Step 5) you will need this information. 
 
Note: If you have a RS232 (Serial) HART modem and you are attempting to use it with a “USB to RS232 converter” 
(e.g. your computer does not have a RS232 port) be aware that many USB to RS232 converters do not provide full 
conversion. Consequently, many converters do not work with RS232 HART Modems. If you are attempting to use a 
USB to RS232 converter and are experiencing problems we recommend you buy a USB HART Modem, or a Bluetooth 
HART Modem. 
 

Step 3: Connect your HART Modem to the HART device 
For communications you must have a suitable load resistance, or a 250Ω Shunt/Loop resistor must be placed in 
series with the device.  Using the clips of the HART Modem connect either: across the loop load resistor (A – B), or 
across the HART transmitter terminals (C – D). See the relevant Figure 1a, 1b or 1c below. 
 
 

 
 
 
 

Figure 1a. Loop Powered HART Transmitter Connection 
 
 
 
 
 
 

Figure 1b. 4-Wire HART Transmitter Connection 
  

Loop 
Power 
Supply 

+ 

- 

HART 
Transmitter 

+ 

- 
Loop Resistor 

 
A B C 

D 

Loop Resistor 

 
C 

A 
Power 
Supply 

+ 

- 

HART 
Transmitter 

+ 

- 

+ 

- 
D 

A B 

http://www.hart-expert.co.uk/online-shop
http://www.hart-expert.co.uk/online-shop/rs232-hart-modem
http://www.hart-expert.co.uk/online-shop/usb-hart-modem
http://www.hart-expert.co.uk/online-shop/bluetooth-hart-modem-hm-bt-bat-er
http://www.hart-expert.co.uk/online-shop/bluetooth-hart-modem-hm-bt-bat-er
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Figure 1c. Multi-drop HART Transmitter Connection 
 
 

Step 4: Activate DevCom2000 
Launch DevCom2000 by selecting the DevCom2000 icon on your desktop.  You can also start the application by going 
to your computer's Start Menu and selecting Start → Programs → ProComSol → DevCom2000 → DevCom2000 to 
launch the program. 
 
You will now be asked to Activate DevCom2000.  If you have Activation Codes (located on the CD case, or sent to you 
by email/letter), select the Activation method of your choice (Manual or Online).  Select the Evaluate option if you 
do not have Activation Codes.  You can use DevCom2000 for 10 days before you need to activate it. 
 
If you are Activating DevCom2000 by the online method, select online activation.  You will be asked to enter the 
Activation Codes on the next screen.  Once entered, DevCom2000 will connect to the Internet to verify the 
Activation Codes.  If you do not have an internet connection, you can activate it by email or phone using the Manual 
Activation method.  Activation details are fully explained later in this manual. 
 
Activation only needs to occur once. 
  

Step 5: Set the DevCom2000 Serial Port (COM Port) Number of the HART Modem 
DevCom2000 uses a default serial port of COM99.  The serial port must be changed from Options → Basic on the 
DevCom2000 menu to the appropriate serial port (COM port) number you noted in step 2.  The other settings on the 
Options tabs typically do not need to be changed. 
 

Step 6: Browsing a HART Device 
You are now ready to inspect, configure, document, etc. a HART device/network. Operating DevCom2000 is similar 
to working with Windows Explorer.  DevCom2000 communicates to the field device, establishes a connection and 
learns its identity.  Once DevCom2000 knows its identity, DevCom2000 locates the device's DD and loads it.  From 
this point forward operation of DevCom2000 is determined by the DD provided by the product's manufacturer.  If a 
DD for the device is not present, a generic DD will be used. 
 
By default, DevCom2000 will open the Browser window.  The organization of the data in this explorer-style window 
is dictated by the device DD.  The left hand tree-pane of this window shows the logical groups of field device data.  
These are called "Menus". The right hand data-pane shows the data, any sub-groups and any standard operating 
procedures found on a given menu. 
 
You can browse through the field device data by expanding (click "+" symbol) or collapsing (click the "-" symbol) the 
menus in the tree-pane.  You can also double-click the folder symbol when seen on the data-pane. 
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Step 7: Modifying the HART Device's Configuration 
The Browser allows access to all of the data exactly as described by the product's manufacturer’s DD.  When you find 
elements of the field device's configuration you want to change, simply double-click and edit the data.  Once you 
have changed the configuration to suit your needs, press the Send icon to commit the data and transfer it to the field 
device. 
 

Step 8: Performing Maintenance and Testing the HART Device 
Many devices perform Methods or Standard Operating Procedures (SOPs) that may need to be performed to ensure 
the device is in peak condition.  These Methods may include calibrating the loop current, trimming the transducer 
values or performing some diagnostic test on the field device.  Methods appear in the data-pane just like data does. 
Double-click on the Method and it will start running in a separate window.  The Method will guide you through the 
process ensuring the procedure is completely and consistently performed.  When the Method is complete the 
window will disappear. 
 

Step 9: Exit 
When you are through working on the field device simply exit DevCom2000.  Once the program exits, you can then 
disconnect the HART interface hardware. 
 

If you have any questions please do contact HART Expert Ltd, advice and support is free. 

HART Expert Ltd 
31 Kingfisher Way 
Romsey 
Hampshire 
SO51 7RY 
United Kingdom 
 
Telephone: +44(0)7966233639 
Email: info@hart-expert.co.uk 
Web: www.hart-expert.co.uk 
 

 

  

mailto:info@hart-expert.co.uk
http://www.hart-expert.co.uk/
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1    INTRODUCTION 
The HART Communicator Software (DevCom2000) allows access to and management of a HART devices.  This 
manual provides the information about the Hardware setup, Communication with HART devices, and functions of 
DevCom2000. 
 
DevCom2000 uses Device Description files (DDs) to access data stored in the memory of the HART field device. 
DevCom2000 is unique in that it uses the DD of the connected device to determine what information to display, 
what variables are available for edit, and what procedures to follow for calibration, setup, and maintenance. 
 
These DDs are developed by device manufacturers for their products and, in turn, distributed by the HART® 
Communication Foundation (HCF) worldwide. The latest DDs are included as part of the DevCom2000 installation, 
and you are automatically sent new DD releases for the first year. At any time (e.g. after the automatic updates have 
ceased) you can download new DD files from the HCF website (www.hartcomm.org). 
 

1.1   Acronyms and Definitions 
 

Acronym Definition 

COTS Commercial-off-the-Shelf 

DD Device Description file, this contains the device information 

DDL Device Description Language 

HCF HART Communication Foundation 

DevCom2000 HART Device Communicator Software 

 
 

1.2   Conventions Used in This Manual 
Following formatting conventions are used in this guide: 
        

Convention Description 

Words in bold type Field names including buttons in the display, or important phrases 

→Arrow Windows pull down menus and their options are separated by →  
For example, click Device → New Device to connect to a new device 

Courier font Information that you type, parts of the code quoted for explanations or as 
examples 

UPPERCASE Acronyms 

UPPERCASE within angle 
brackets 

Command keys 
For example, press <ENTER> 

 

1.3   Document Organization 
DevCom2000 user manual is organized into the following sections: 
 

Section 1 Describes the scope and objective of DevCom2000 user manual along with the 
organization of the remaining part of the manual 

Section 2 Provides an overview of the DevCom2000 application and its architecture 

file:///C:/Users/Robin/Cloud_HART-Expert/Downloads/HART_Expert_website_content/www.hartcomm.org
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Section 3 Provides the information pertaining to hardware and software requirements for 
the DevCom2000 application 

Section 4 Provides the steps to install, activate, and uninstall the DevCom2000 application 

Section 5 Provides the steps to start the DevCom2000 application and connecting to field 
devices 

Section 6 This section explains different aspects of the DevCom2000 application and its 
functionalities 

 

1.4   Getting Help 
If you need help or encounter problems when using DevCom2000 or this guide, please contact HART Expert Ltd. See 
Appendix B for contact information.  Please provide the following information. 
 
Create a text description of the problem.  If possible, provide the text in event sequence, which will enable the 
duplication of the problem.  Provide information about the system. This information must include: 
 

•   DevCom2000 version and License ID 
 
•   Computer information: make, model, CPU type, clock speed, attached peripherals and operating 

environment (Windows version) 
 
•   HART Device information: make, model, and device revision 
 
•   Point of contact: complete mailing address, telephone number, and e-mail address, 
 
•   The date and time of the problem occurrence  
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2    OVERVIEW OF DEVCOM2000 
Field devices such as flow, pressure, level, temperature transmitters, and valve positioners provide the physical 
connection to the process. These devices allow the control system to monitor and manipulate process conditions. 
HART devices maintain a real-time database of process, configuration, identification, and diagnostic information. 
This information can be accessed using the HART Field Communications Protocol. 
 
HART devices are capable of providing functions and features far beyond the basic task of providing a process input 
or accepting a control output to manipulate process conditions.  Many HART compatible device manufactures create 
a DD (Device Description) describing all of these functions and features specific to that device. The DD also provides 
information essential to the successful configuration and calibration of the device. 
 
DevCom2000 uses these DD’s to access the data stored in a device, providing full configuration and setup support for 
all registered HART DD’s. 
 
DevCom2000 accesses and presents field device data based solely on its DD.  No other files, information or custom 
drivers are required. DevCom2000 is intended to monitor and configure a single device at a time, it is directly 
connected to the current loop of the particular device and: 
 

•   Provides user interface to configure the HART field device, 
 
•   Provides a means to configure and view all the parameters related to HART field device, and 
 
•   Provides an option to view the detailed status and diagnostic capability of the device. 

 
DevCom2000 allows viewing and modifying of field device parameters based on the DD.  Using the device’s DD, 
DevCom2000 performs various tests to verify the proper operation of the HART device.  DevCom2000 runs as a 
standalone software package and must have a HART compatible modem attached to the system to interrogate the 
HART base devices.  A HART modem is not required for HART-IP communications to a WirelessHART Gateway. In this 
case, an Ethernet connection is required. 
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3    SYSTEM REQUIREMENTS 
The following minimum system requirements are recommended for operation of DevCom2000. 
 

PC                                        Processor Speed: Pentium, 600 MHz 
Memory: 256 MB 
Hard Disk Space: 500 MB 
Monitor: 256-color VGA 

HART Modem USB HART modem, or Bluetooth HART modem, or RS-232 HART modem (HART 
Expert Ltd supplies HART modems). Not needed for HART-IP or WirelessHART 

Communication Port USB, Bluetooth, or RS-232.  Ethernet for HART-IP or WirelessHART 

Operating System Windows 32 and 64 bit versions: XP, Vista, 7, 8, 8.1, and 10 

 

  

http://www.hart-expert.co.uk/online-shop/usb-hart-modem
http://www.hart-expert.co.uk/online-shop/bluetooth-hart-modem-hm-bt-bat-er
http://www.hart-expert.co.uk/online-shop/rs232-hart-modem
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4    DEVCOM2000 INSTALLATION 
4.1   Prerequisites 
You need to be familiar with the basic functions of the following when installing DevCom2000: 
 

•   Microsoft Windows 32 and 64 bit versions: XP, Vista, 7, 8, 8.1, and 10 
 
•   A HART communication interface (e.g. HART Modem, HART-IP, WirelessHART, etc.) 
 
•   A HART field device (e.g. a HART Transmitter such as Pressure, Temperature, Flow, etc) 

 

4.2   Installing the DevCom2000 Application 
To install the DevCom2000 application in a standalone system, perform the following steps: 
 

Step Action 

1 Insert the DevCom2000 CD into the CD-ROM drive. Auto run should begin installation, if 
not: 

2 Click Start and choose Run. From the Run window, click Browse. 

3 In the Look In box, browse to your CD drive. 

4 Double-click the drive to access the CD content. 

5 Look for the DevCom2000Setup.exe file and double-click the same. This process will take 
you through a sequence of installation wizard steps. 

6 Follow the instructions on the upcoming screens to complete the Installation. 

 

4.3   Activating DevCom2000 
On first use you will be asked if you want to Activate DevCom2000 (requires a license key) or Evaluate DevCom2000.  
If you choose to evaluate DevCom2000 it will not run after 10 days.  The following describes the procedure. 
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Step Action 

1 Start the DevCom2000 Application.  If this is the first after installation the following window is 
displayed: 

 
If you want to evaluate DevCom2000 before purchasing, select the “Evaluate DevCom2000” option.  
You will have 10 days of unlimited program use before you will need to purchase a license. 
If have not already purchased a DevCom2000 license from the HART Expert Ltd online shop 
(www.hart-expert.co.uk) you can select “Purchase DevCom2000 Online” which will take you to the 
USA based ProComSol Ltd website. Licenses for DevCom2000 can be purchased online from both 
HART Expert Ltd and ProComSol Ltd. 
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Step Action 

2 If “Activate DevCom2000” is selected, the following Activation window appears: 

 
 

3 If the “Activate DevCom2000 Online” option is selected, the following window appears. 

 
Enter the information from License Key email or the Activation label on the CD case. Select 
“Continue” to process the information. If the codes were successfully entered, the program will 
continue as normal.  You will not need to perform the activation process again. 
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Step Action 

4 If the “Activate Manually” option is selected, the following window appears: 

 
You will then need to contact HART Expert Ltd (UK) or ProComSol Ltd (USA) to obtain the Activation 
Codes.  You must supply the User Codes to the support personnel (your user codes will be different 
than those shown here).  You can register manually in either of the following ways: 
 

• Call HART Expert Ltd (UK) on +44(0)7966233639, or ProComSol Ltd (USA) on 
+1.216.221.1550. Please have the program License ID and User Codes ready. 

 

• Send an email to support@hart-expert.co.uk (UK) or support@procomsol.com (USA) 
containing your company name, License ID, and User Codes. 

 
The above information will enable us to create the Activation Code information that you will need 
to enter. If activation is successful, the program continues as normal.  You will not need to perform 
the activation process again. 

 
We have tried to make the Activation process as easy as possible.  Contact HART Expert Ltd if you have any 
difficulties. 
  

4.4   Connecting to the HART Network 
The DevCom2000 application communicates with the HART Field Devices through a HART compatible 
communication interface (e.g., a "HART Modem", “HART-IP”, “WirelessHART”, etc.).  Using this communication 
interface, you will transmit real-time HART data between DevCom2000 and the connected HART compatible field 
device(s). 
 
There are a wide variety of HART compatible interfaces.  Please follow the manufacturer’s instruction for connecting 
your interface to the PC.  This manual assumes you will be using the USB HART Modem manufactured by ProComSol 
Ltd, called HM-USB-ISO. 
 

mailto:support@hart-expert.co.uk
mailto:support@procomsol.com
http://www.hart-expert.co.uk/online-shop/usb-hart-modem
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Insert the USB connector on the HM-USB-ISO into your computer’s USB port.  Using the clips on the wires from the 
HART interface, connect to the device across the 4-20ma signal.  If a suitable load resistance is not available, a 250Ω 
resistor must be placed in series with the device power supply. 

 
Figure 1 Typical DevCom2000 Hardware Setup 

 

4.5   Uninstalling the DevCom2000 Application 
To uninstall the DevCom2000 application, perform the following steps: 
 

Step Action 

1 Click Start → Programs → ProComSol → DevCom2000 → Uninstall DevCom2000 

2 Or, Click Start → Settings → Control Panel → Add/Remove Programs 

3 In the Add/Remove Programs dialog window, select the DevCom2000 program that you 
want to uninstall. 

4 Click Remove. 

5 Click OK to confirm the removing of the selected application. 
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5    USING DEVCOM2000 
5.1   Starting DevCom2000 
The HART compatible field device must be connected to a PC or tablet running DevCom2000 to configure or calibrate 
the field device, or to view the field device's data.  Make sure to establish the physical connection between the field 
device and the DevCom2000 computer.  With the physical connection established, launch DevCom2000 by clicking 
the DevCom2000 icon on your desktop.  You can also start the application by going to your computer’s Start Menu 
and selecting Start → Programs → ProComSol → DevCom2000 → DevCom2000. 
 
If your computer is running an anti-virus program such as McAfee, you may get a message about a program wanting 
to access the internet.  This is normal.  DevCom2000 uses TCP/IP to communicate with the Communication Log 
program. 
 

Step Action 

1 Start the DevCom2000 Application.  The following application window is displayed: 

 
DevCom2000 will then automatically identify the field device and open a communication channel to 
(i.e. a connection with) the field device. 
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Step Action 

2 Setting Options  Options → Basic 
If communications cannot be established, you may need to change the communication settings 
using the Options dialog box. The serial port box will show the available com ports.  Select the one 
your HART modem is using. 

 
 

3 You may also change the polling options for the computer.  If you do not know the poll address of 
the device you are trying to communicate with, use the default address 0 setting. To do this either 
click on the Search By tab or go to Options → Search 

 
Make sure that Poll Address under Search By is selected. 
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Step Action 

4 When the device is connected to DevCom2000, the browser window appears with online (i.e. root 
menu) selected. 

 
The left pane of the window shows the menu structure and the right pane of the window displays 
corresponding parameters of the menu selected. 
The DevCom2000 screens shown in this document are only an example of what you may see when 
connected to your field device. What you see is actually controlled by the devices DD file and the 
device.  Hence, the menus, data, status and configurations displayed are specified by the field 
device's manufacturer when they release the devices DD file. 

5 Select the required menu to configure or review the field device's data. 

 

5.2   Getting Familiarised with DevCom2000 Explorer 

5.2.1    Using the Menus 
DevCom2000 Explorer provides visual representation and structure of the application window. 
 

Menu Explanation 

Device Menu 

 

The Device Menu offers the following sub-menu options: 
New Device - Connect to a new device or reconnect to the same device. 
Document Device – Brings up the Document Device dialog box. 
Download / View – Brings up the Download dialog box which provides 
Configuration File features. 
Exit - Exit DevCom2000. 

Options Menu 

 

The Options Menu offers the followings sub-menu options: 
Basic- Select what COM port the device is connected to and use 
WirelessHART gateway. 
Search- Search by Poll Address, Long or Short Tag. 
Advanced- Select HART Master, Language, and DD Startup 
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Menu Explanation 

View Menu 

 

The View Menu offers the following sub-menu options: 
Toolbar - Hide or show the Tool Bar. 
Status Bar - Hide or show the Status Bar. 

Communication Log – Open the Communication Log window. 
Device Condition – View detailed device status. 
Event-Status Log – View log of events and status changes 

Example of an available 
Enhanced Menu 

 
 
Example of an unavailable 
Enhanced Menu 

 

The Enhanced Menu offers enhanced device menus.  Some devices do not 
have enhanced menus, this is controlled by the device manufacturer and 
is specified in the devices DD file. If a device does not have an enhanced 
menu, this menu will only say “Enhanced View Below (if available)”. To 
the left are two examples, first a device with enhanced menus, second a 
device without enhanced menus. 

Trending Menu 

 

The Trending Menu offers the following sub-menu options: Define Trend 
– Brings up the Define Trend dialog box where a trend is started. 
View Current Trend – Brings up a real time graph of values currently being 
trended. 
View Past Trends – Brings up the View Trend dialog which contains past 
trend files. Selected trend files can then be graphed. 
Stop Current Trend – Stops the current log in process. 

DD Menu 

 

The DD Menu offers the following sub-menu options: 
Add DD – Brings up the dialog that adds a DD to the library. Also used to 
give labels to non-standard library DDs. 
Available DDs – Brings up a browser of all the DDs installed in the library. 

DTM Menu 

 

The DTM Menu offers the following sub-menu options: 
Launch FDT Frame– launches the FDT Frame program. 

Help Menu 

 

The Help Menu offers the following sub-menu options: 
DevCom2000 Help – Brings up Help information for the DevCom2000 
application. 
Com Troubleshooter – Brings up the DevCom2000 Com Troubleshooter. 
Device Help – Brings up help information for the connected device (if 
available). 
About DevCom2000 – Shows copyright information, support information, 
and application Version Number. 

 

5.2.2    Using the Toolbar 
When you start the application, by default, the toolbar buttons appears on the main window.  If it fails to display, 
click View → Toolbar option from the menu bar to bring up the toolbar. 
 
Following are the buttons available in the DevCom2000 application toolbar to perform the necessary tasks: 
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Button Description Corresponding Menu Option 

 
Connect to a new device Device → New Device 

 
Send parameter changes to the device  

 
Cancel parameter changes  

 
View more status on Device and 
Communication (Command 48 status) 

View → Device Condition 

 
View Communication log View → Communication log 

 View Event log View → Event-Status log 

 
Launch FDT Frame (Future) DTM → Launch FDT Frame 

 

5.2.3    Familiarising with Icons 
DevCom2000 application uses different icons to represent different elements of the application. The following table 
lists the icons and their meanings: 
 

Icon Meaning 

 Indicates a menu or submenu in the navigation tree 

 
Indicates a currently selected menu or submenu in the navigation tree 

 

Online menu icon.  The actual DD menu comes under this. 

 

Indicates a “Variable” item 

 

Indicates a “Method” (Standard Operating Procedure) item 

 

Indicates an “Edit Display” item 
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6    FUNCTIONS AND BASIC OPERATIONS 
6.1   Overview 
DevCom2000 allows the user to monitor and configure HART devices.  Each device is associated with the DD when 
the device information is present. A DD may contain any of the following parameters/elements: 
 

Variable 
A variable is defined as the data contained in the device (e.g. Device Firmware Version). There are two types of 
variables: 
 

• Editable Variable – It allows the operator to modify the value and download it to the device. 
 

• Non-Editable Variable – It is a read-only data from the device. 
 

Edit Display 
This option is used to view a group of parameters. You can also modify a single parameter from this group, based on 
which other parameters of the device get altered. 
 
For example, if the Engineering Unit of the device is modified, the corresponding Low Limits and High Limits change 
as per the Engineering Unit set. 
 

Method / Standard Operating Procedure (SOP) 
This option helps to perform various tests on the device for instance, Self Test and Loop Test.  A Method or SOP is a 
series of steps that are executed in a sequence results in the completion of some device related tasks.  When a 
method gets invoked, it gives various warning messages and options to the user, by which the user can thoroughly 
test the device.  If a test is aborted by operator command at any stage of the sequence, the method invokes 
additional steps to bring the device back to its original state before the test was commenced. 
 

6.2   Viewing Device Configuration (typical, actual view may change based on DD) 
To view the configuration of the device that is connected to DevCom2000, perform the following steps: 
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Step Action 

1 Ensure that the application is running and communications have been established: 

 
The left pane of the window shows the menu structure and the right pane of the window displays 
corresponding parameters of the menu selected. 
The menus that are displayed are defined in the DD file of the particular device. 
If no DD is available for the device DevCom2000 will select the standard DD.  This should provide 
limited functionality for the device.  NOTE: If a parameter is updated that is not supported by the 
device you will receive an error. 

2 Expand the menu by clicking the “+” sign and double-click to view the device parameters. Below is 
an example of an expanded menu: 

 

3 Repeat Step 2 to expand sub-menus if required and then select the desired menu / sub-menu to 
view the associated parameters / device information. 

 

6.3   Configuring Device Information 

6.3.1    Overview 
DevCom2000 allows you to view and configure the field device parameters based on the Device Description (DD) file. 
However, the device vendor defines most of the parameters at the factory. These parameters become read only for 
the users and the user cannot modify the values. The related variables are grouped under various menus of different 
levels as defined by the device vendor in the DD file. Expand or collapse the tree view using the “+” or “-“sign to 
access the device configuration parameters. 
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The following table describes the details about the device configuration: 
 

Step Action 

1 Follow the steps in section “6.2 Viewing device configuration” to view the device parameter(s) you 
want to change, e.g.   

2 There are three types of variables: dynamic, read/write and read only.  The parameters that are 
grayed out indicate that these are dynamic variables (variables that get updated online by the 
device) or read only variables. 
The status of device parameters are represented as follows: 
Bold Font = Modifiable Values 
Normal Font = Menu Item 
Gray Font = Dynamic or Read Only Variables 

3 From here you can select the parameter and configure the values, as required. However, there are 
several types of parameter and the topics in the following sections explain how to configure the 
different device parameter types. 

 

6.3.2    Variable 
To edit the parameter variables of the connected device, perform the following steps: 
 

Step Action 

1 Follow the steps in section “6.2 Viewing device configuration” to view the device parameter(s) you 
want to change, e.g.   
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Step Action 

2 Double-click the variable to edit it. The following dialog box appears on the screen: 

 

3 Make the changes to the parameter value, as required. 

4 Click Set to accept the changed value. The change gets reflected as shown: 

 

5 Click on the Send icon  to commit the changes to the device. 
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Step Action 

6 When the value is no longer yellow, the variable has been changed in the device. 

 
The Send and Cancel Icon will now be grey as well. This indicates that there are no new changes to 
be sent to the device. 

 

6.3.3    Edit Display 
The Edit Display is a variation on the Variable edit.  An additional window helps the user view a group of parameters 
based on the DD. You can also modify a single parameter from this group.  Parameters linked to the edited field will 
be updated automatically. 
 
To view and configure these variables, perform the following steps: 
 

Step Action 

1 Follow the steps in section “6.2 Viewing device configuration” to view the device parameter(s) you 
want to change, e.g.   
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Step Action 

2 Double click the parameter you wish to edit.  The following dialog box appears on the screen: 

 

3 Double click the parameter you wish to edit.  The following dialog box appears on the screen: 

 

4 Make the change to the value, as required. 
 

5 Click Set to accept the changes.  Or press Cancel to cancel the changes. 

6 Click OK to close the dialog box. 

 
Again the yellow means the parameter is changed and ready to be sent to the device. 
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Step Action 

7 Click on the Send icon  to commit the changes to the device. 
 

After being sent the change is reflected in the device info. 

 

6.3.4    Executing Methods or Standard Operating Procedures 
Methods are defined in the DD file for the device that DevCom2000 is connected to. You can select the Method and 
execute it for calibrating the device, trouble shooting, etc.  Method execution leads you through a number of steps, 
like in a wizard. 
 
A Few examples of methods include: 
 

• Setting high and low range calibration points 

• Calibration of the device 

• Run the advanced diagnostic test procedure 

• Execute tests to gather information on device operation. To execute a Method, perform the following steps: 
 

Step Action 

1 Follow the steps in section “6.2 Viewing device configuration” to view the device parameter(s) you 

want to change, select the parameter where the method is present and double-click to open 
it. 
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Step Action 

2 Click Set to open the Method dialog box (below is an example of a Method dialog box): 

 

3 Click either: 

• OK to move to the next dialog in the Method sequence. 

• Abort to cancel the Method execution. 

• Help to get specific help for that step of the Method.  This Help information is provided by 
the device DD. 

     
 

6.4   Calibrating HART Field Devices 
Calibration of field devices and loop test are achieved by executing the Methods or Standard Operating Procedures 
that are specific to device.  Methods are defined based on the test parameters specific to the device, providing 
information for the calibration of that device. 
 
See the previous section for Method execution. 
  
 
 

6.5   Viewing the Device Status 
DevCom2000 provides the user with the ability to monitor the device specific status of the device and the 
communication network. 
 
When there is error communicating with the device, it is recognized and indicated to the user. The user can view 
more details of such errors, using the View → Device Condition from the main window. 
 
To view the device and communication status, perform the following steps: 
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Step Action 

1 Ensure that the application is running and communications have been established: 

 

2 Select View → Device Condition from the main window or choose the status icon  from the 
toolbar. Following window is displayed: 

 
The Device Status tab option shows the status of the device and the communication network. The 
individual status is indicated by green and red LEDs. 

4 Additional tabs may be available depending on the DD. 

5 Click X to close the Status window. 

 

6.6   Viewing the Communication Log 
DevCom2000 allows the user to view the actual communications between DevCom2000 and the device.  You can 
view send commands and received responses. 
 
If your computer is running an anti-virus program such as McAfee, you may get a message about a program wanting 
to access the internet when you open the Communication Log.  This is normal.  DevCom2000 uses TCP/IP to 
communicate with the Communication Log program. 
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If no data appears in the Communication Log, this may be due to an anti-virus program.  Close the Log window and 
re-launch. 
To view the communication log, perform the following steps: 
 

Step Action 

1 Ensure that the application is running and communications have been established 

 

2 Select View → Communication Log from the main window or choose the communications log icon   
from the toolbar. The following window is displayed: 

 
Note: The communications log lists actual HART commands and the responses from the unit.  A 
good understanding of the HART protocol is required to interpret this data. 

3 Select File → Exit to get back to the main window.  Or, close the 
Communication Log window by clicking on the X. 

 

6.7   Viewing the Event-Status Log 
DevCom2000 allows the user to view the error conditions of the device and the communication network. 
 
To view the Event-Status Log, perform the following steps: 
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Step Action 

1 Ensure that the application is running and communications have been established: 

 

2 Select View → Event-Status Log from the main window or choose the Event-Status log icon  
from the toolbar. An additional Event Status window is displayed: 

 

3 To close, go to View → Event-Status Log menu option or click on the  icon to go back to the 
original window. 

 

6.8   Saving Device Configuration to Disk 
HART Device configurations can be saved to disk as a text file to document the device.  Fields are delimited with a 
comma so that the data can be imported into configuration management software packages.  A PDF version of the 
configuration is also created. 
 
To save device configurations to disk, perform the following steps: 
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Step Action 

1 Ensure that the application is running and communications have been established: 

 

2 Select Device → Document Device from the main window.  The 
Document Device Dialog Box is displayed: 

 

3 The default directory is based on Windows User Accounts.  The default file name is Tag Device ID.  
The directory and filename can be changed by the user.  Use the “Browse” button to change 
directories and/or filenames also. 

4 Enter a Note in the Notes: field if desired.  Maximum of 250 characters. 

5 Press the “Save Device Config” button to save device configuration. 
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Step Action 

6 If the filename has already been used, the following Dialog Box is displayed when Save Device 
Config is pressed: 

 
 

• Append: Adds the number shown to the end of the file name 

• Overwrite: Deletes and writes over the existing file 

• Cancel: Returns to the previous menu 

  

 

6.9   Download Configuration to Device 
Saved configuration files can be downloaded back to devices.  This is useful for “Cloning” a device, either for 
replacement or plant setup. 
 
To save device configurations to disk, perform the following steps: 
 
  

Step Action 

1 Ensure that the application is running and communications have been established: 
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Step Action 

2 Select Device → Download from the main window.  The Download 
Dialog Box is displayed: 

 

3 The available configurations are displayed.  You can sort on each column by clicking it. 
To get details about a configuration, select the desired configuration and double click it.  The details 
will be displayed below. 

4 You can change the desired Tag by editing the Configuration File Tag box. You can change the 
desired Description by editing the Config. File LongTag/Desc box. 

5 Press the “Write” button to write device configuration.  The device must be the same type as the 
configuration file.  If they are different, the write operation will be aborted. 

6 You can view the PDF file for the configuration file by double clicking on the desired configuration 
and pressing “View”. 

7 You can delete configurations by double clicking on the desired configuration and pressing “Delete”. 

 

6.10   Customizing PDF File Output 
HART Device configurations can also be saved to disk as PDF Files to document the device.  The header, footer, and 
technician name can be entered to customize the PDF file to make it into a configuration report. 
 
To customize the PDF output, perform the following steps: 
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Step Action 

1 

 
Press the “PDF Setup” button on Document Device Dialog Box: 

2 The PDF Setup Dialog box is displayed: 

 

3 Enter data as needed and press OK.  The data is saved for future configuration saves. 
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Step Action 

4 Below is a sample PDF file. 

 

 

6.11   License File Transfers 
The license file can be transferred easily to other computers.  The process is a “Check-In/Check-Out” process. When 
a license is on the computer, it is considered “Checked-Out”.  When the license is on the license server, it is 
considered “Checked-In”. When the license is “Checked-in”, it can be “Checked-Out” by other users.  This enables 
the license to be shared by many users. 
 

6.11.1   Check-In 
To Check-In the license from the current computer to the License Server, perform the following steps: 
 

Step Action 

1 Verify your PC is connected to the Internet. 

2 Select “Check-In” from the “License” Menu. 
If the current computer is not licensed, an error message will appear.  If licensed, the program will 
contact the License Server via the internet.  It will check-in the license using the License ID and 
Password used in Activation.  The current computer will then become un-activated. 
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6.12   Options Menu 

6.12.1   Options → Basic 

6.12.1.1    Changing the COM port 
The Basic menu is used to set the COM port to the correct one that the device is connected to.  To change the 
COM port, perform the following steps: 
 

Step Action 

1 Ensure that the application is running. 

 

2 Select Options → Basic from the main window.  The Options Dialog 
Box is displayed with the Basic tab selected: 

 

3 To change serial ports, Click on the drop down box: 
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Step Action 

4 Once the desired COM port is selected click OK to save the changed settings. 

5 Click Yes if you want to save the changes. Clicking No will not save the changes. 

 

6 Select New Device from the Main screen to connect using the new 
COM port. 

 

6.12.1.2   Use HART-IP with a WirelessHART Gateway 
The Basic menu is where DevCom2000 can be set to use HART-IP to communicate with a WirelessHART Gateway.  To 
communicate using HART-IP with WirelessHART Gateway, perform the following steps: 
 

Step Action 

1 Ensure that the application is running. 
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Step Action 

2 Select Options → Basic from the main window.  The Options Dialog Box is displayed with the Basic 
tab selected: 

 

3 Click “Use TCP/IP with WirelessHART Gateway” 

 
The Serial Port option will now be grayed out.  Un-checking will make Serial Port selectable again. 

4 Enter the IP Address of the WirelessHART Gateway in the IP Address Field.  Also enter the Port 
assigned to HART-IP in the Gateway.  It is typically 5094. 
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Step Action 

5 For more advanced settings related to HART-IP, click the “Advanced” tab.  The following dialog box 
appears: 

 
 
Communicating to a WirelessHART Gateway via its URL: 
 
Gateway URL 
Enter a URL text address in the URL field and click the “Resolve” button to convert it into an IP 
Address.  The IP Address will populate the IP Address box if a successful conversion occurs. 
 
Gateway HART Address 
Some WirelessHART Gateways do not use the default address of 0. For these Gateways you must 
enter the correct Gateway Address in this field. 
 

 

6.12.1.3   Using HART Server 
The Basic menu is used to set DevCom2000 to communicate with a WirelessHART gateway or HART multiplexer.  
This requires an external program called HART Server.  Although DevCom2000 can use HART Server for 
WirelessHART communications, it is recommended that HART-IP be used.  To communicate with a WirelessHART 
Gateway or a HART multiplexer, perform the following steps: 
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Step Action 

1 Ensure that the application is running. 

 

2 Select Options → Basic from the main window.  The Options Dialog Box is displayed with the Basic 
tab selected: 
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Step Action 

3 Click “Use HART server with WirelessHART Gateway or HART Multiplexer” 

 

4 The Serial Port option will now be grayed out.  Un-checking will make Serial Port selectable again. 
Click OK to save the changed settings. 

5 Click Yes if you want to save the changes. Clicking No will not save the changes. 

 

6 Restart DevCom2000 for the changes to take place. 

 

6.12.3   Options → Search 

6.12.3.1   Poll Address 
The Search menu is used to change how DevCom2000 searches for a Device.  The first option is to search by Poll 
Address.  This searches for a specific poll address or set of addresses. To search for a device using Poll Address 
perform these steps: 
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Step Action 

1 Ensure that the application is running. 

 

2 Select Options → Search from the main window.  The Options Dialog Box is displayed with the 
Search By tab selected: 
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Step Action 

3 Select one of options for Poll address: 

• “use poll address 0 only” only searches at poll address 0 before not finding a device.  This is 
the default setting. 

• “find first poll address” searches poll addresses until it finds the first device it comes across. 

• “use poll address:__” If the poll address is know this options searches at a specific address 
(i.e. 5). 

• “search 0-15” searches poll addresses 0 through 15. 

• “search 0-31” searches poll addresses 0 through 31. 

• “search 0-63” searches poll addresses 0 through 63 

• “search range__ through__” searches between a user identified range of poll addresses. 
 
If using a WirelessHART adapter you can also click to select the devices default address, e.g.: 

• “MACTek Bullet – 15” searches poll address 15. 

• “Emerson THUM - 63” searches poll address 63. 

• Etc. 

4 The Search by Tag option is grayed out when searching by poll address is selected.  Select a search 
by poll address option and Click OK to save the changed settings. 

5 Click Yes if you want to save the changes. Clicking No will not save the changes. 

 

6 Reconnect to a new device. 

 

6.12.3.2   Short Tag 
The Search menu can also be used to search by a specific Tag name or Description.  To search for a device based on a 
Tag name or a Description, perform the following steps: 
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Step Action 

1 Ensure that the application is running. 

 

2 Select Options → Search from the main window.  The Options Dialog Box is displayed with the 
Search By tab selected: 

 
3 Select “Short Tag” from the Search By drop down box. 

 
4 The poll address options will now be grayed out.  Enter the tag to be searched for in the “Search by 

Tag” edit box. 
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Step Action 

 
5 Click OK to save the changed settings. 

6 Click Yes if you want to save the changes. Clicking No will not save the changes. 

 
7 Reconnect to a new device. 

 

6.12.4   Options → Advanced 

6.12.4.1   HART Master 
The Advanced menu is used to change DevCom2000 settings.  DevCom2000 can be a Primary or 
Secondary HART Master. To change the HART Master setting, perform the following steps: 
 

Step Action 

1 Ensure that the application is running. 
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Step Action 

2 Select Options → Advanced from the main window.  The Options 
Dialog Box is displayed with the Advanced tab selected: 

 

3 Under the section “HART Master” select either “Primary” or 
“Secondary”. 

4 Click OK to save the changed settings. 

5 Click Yes if you want to save the changes. Clicking no will not save the changes. 

 

6 Restart DevCom2000 for the changes to take place. 

 

6.12.4.2   Language 
Certain DD’s can be used in different languages.  English is the default setting but some support other languages.  
Note that main program frame will always be English.  Only the DD based items – menus, variables, etc. will change 
language.  And will only change if the DD supports that language.  In order to change the Language setting, perform 
the following steps: 
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Step Action 

1 Ensure that the application is running. 

 

2 Select Options → Advanced from the main window.  The Options Dialog Box is displayed with the 
Advanced tab selected: 

 

3 Click the “Select Language” drop down to select a different language. 

 

4 Select a language to translate the DD into. Click Okay to save the changed settings. 
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Step Action 

5 Click Yes if you want to save the changes. Clicking no will not save the changes. 

 

6 Restart DevCom2000 for the changes to take place. If the language is supported the DD will be 
translated. If not, the DD with default to English. 

 

6.12.4.3   DD Startup 
During normal startup of DevCom2000, the device is found and then the DD is loaded.  If the DD cannot be found 
then a generic DD is loaded. Advanced has settings that can change what DD DevCom2000 loads with loading a 
device.  To load a generic DD at start up or to not load a DD at all perform the following steps: 
 

Step Action 

1 Ensure that the application is running. 
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Step Action 

2 Select Options → Advanced from the main window.  The Options Dialog Box is displayed with the 
Advanced tab selected: 

 

3 Click either “Device DD” or “Generic DD” depending on which DD is to be loaded when connecting 
to a device. 

4 Check the “Don’t Connect to Device On Startup” to start DevCom2000 without connecting to a 
device.  Clicking “New Device” will connect to a device after this start up. 

5 Click OK to save the changed settings. 

6 Click Yes if you want to save the changes. Clicking no will not save the changes. 

 

7 Restart DevCom2000 for the changes to take place. 

8 If  “Don’t Connect to Device On Startup” is checked the following message will be displayed on start 
up: 
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6.12.4.4   Default Settings 
The “Default” button on the Advanced tab Options resets all the advanced options to their default settings. To 
return the settings to their default settings perform the following steps: 
 

Step Action 

1 Ensure that the application is running. 

 

2 Select Options → Advanced from the main window.  The Options 
Dialog Box is displayed with the Advanced tab selected: 

 

3 Click the “Restore Defaults” button. 

4 DevCom2000 will ask if you want to restore the default settings. Click “Yes” 
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Step Action 

5 If the restore was successful the following dialog box will be shown: 

 

6 Click OK to save the changed settings. 

7 Click Yes if you want to save the changes. Clicking no will not save the changes. 

 

8 Restart DevCom2000 for the changes to take place. 

 

6.13   Trending 

6.13.1   Define Trend 
The Trending menu is used to track dynamic device parameters over a specified period of time.  Once a parameter is 
tracked, it can be graphed and compared against other parameters tracked on the same time period.  Before a 
parameter can be graphed, a trend must first be created. To create a trend, perform the following steps: 
  

Step Action 

1 Ensure that the application is running and is connected to a device. 
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Step Action 

2 Select Trending → Define Trend from the main window.  The Define Trend Dialog Box is displayed: 

 

3 Select the information for the log file: 

• Select Parameter(s) – Select up to four parameters to log at a time. Press the CNTRL key to 
select multiple parameters. 

• Enter Interval - Input a number and select an interval from the drop down box, i.e. Seconds, 
Minutes, Hours, Days. 

• For How Long? – Input duration for how long to log the parameter(s).  This part will be 
grayed out if the “Continuous” check box is selected.  Unselect it for a finite duration. 

• Enter Filename – The default directory is based on Windows User Accounts however a log 
file can be saved anywhere. 

• Notes – The section can only be 250 characters long. 

4 Click the “Start” button to start logging. 

5 The logging will then be started. At the lower right hand corner of DevCom2000 the “Trend Activity” 
light will come on.  This indicates that there is logging going on.  You cannot start another log until 
this one is finished or the user stops the trend manually. 

 
 

6.13.2   View Current Trend 
When a trend is created DevCom2000 creates a window that shows the graph of the current trend.  To view this 
trend, perform the following steps: 
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Step Action 

1 Ensure that the application is running and is connected to a device. 

 

2 Ensure that a trend is in progress.  The “Trend Activity” light at the bottom of the screen is on if a 
trend is in progress. If not then the light will be off. 

 

3 Select Trending → View Current Trend from the main window. 
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4 The DevCom2000 Trend dialog opens up. 

 
The user can manipulate the graph as desired.  “Tracking” is the term used to describe how the 
graph control follows the data, changing the axis in real time so that all of the data is shown. Below 
are the specific parts of the graph: 
Tool Bar: There are multiple things that the user can do with the graph. 

 
Resume All Tracking: The “Resume All” button -  - is grayed out while tracking.  If either axis is 

changed or the “Pause” button is pressed, this will be come green -  - Pressing “Resume All 
Tracking” will resume the tracking on the graph. 

Pause All Tracking: The “Pause” button -  - pauses the graph in its current state.  Data is still 
added, however the current X-axis and Y-axis spans no longer change.  Pressing the “Resume” 
button will continue tracking. 

Scroll Axis: This is the default way to scroll both the X and Y-axis. The “Scroll Axis” button -  - 
allows the user to scroll in both directions on the graph. 

Zoom Axis: The “Zoom Axis” button -  - allows the user to shrink or enlarge the scale of either 
axis.  By moving up or down, left or right, the span of each axis is changed. 

Zoom Out All Axis: The “Zoom Out All Axis” button -  - zooms out both the X-axis and Y-axis at 
the same time giving the user a broader look at the graph. 

Zoom In All Axis: The “Zoom In All Axis” button -  - zooms in both the X-axis and Y-axis at the 
same time giving the user view over a smaller time period. 

Zoom Box: The “Zoom Box” button -  - changes the cursor allowing the user to select a specific 
area of the graph to zoom in on for a more detailed look. 

Cursor: The “Cursor” button -  - adds a cursor to the screen that gives the coordinates of the 
graph at a certain time. Clicking and moving the cursor can give the coordinates of any point on the 
graph. See below for an example of using the “Cursor” tool: 
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Step Action 

 

Properties: The “Properties” button -  - brings up the “Properties” dialog box which gives the 
user the ability to customize the graph as desired.  Below is an example of one of the “Properties” 
tabs: 

 
 

Copy To Clipboard: The “Copy To Clipboard” button -  - copies the graph to the clipboard to 
allow the graph to be pasted into documents like a report. 

Save: The “Save” button -  - saves the graph as a “*.bmp”. 

Print: The “Print” button -  - prints the graph. 

Preview: The “Preview” button -  - gives a print preview of the graph. 
Title: The title gives the name of the parameter being trended, the units that the parameter is being 
measured in, and the date(s) of the graph, e.g. 
 

(Parameter)        (Units)    - (Date yyyy/mm/dd) 

 
 
Axis: The Y-axis is the units of the parameter.  The X-axis is the time in HH:MM:SS format. 
Redraw: This section is disabled for View Current Trend. 

 

6.13.3   View Past Trends 
DevCom2000 keeps a list of trends that have been done in the past.  These trends are saved so that they can be 
viewed at a later date.  To select a trend to be viewed perform the following steps: 
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Step Action 

1 Ensure that the application is running, you do not have to be connected to a device to use View Past 
Trends. 

 

2 Select Trending → View Past Trends from the main window. 

3 The Select Trend To Graph dialog will open. 

 
This dialog box is very similar to the “Download/View” dialog box. 
Data: Opens the text file where the data has been saved. 
Delete: Deletes a previous trend from the database. 
Close: Closes the dialog box. 
Trend: Opens the saved Trend and displays it graphically. Select a trend to graph and click “Trend”. 
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4 The DevCom2000 Trend dialog opens up when “Trend” is selected. 

 
The user can manipulate the graph as desired.  “Tracking” is the term used to describe how the 
graph control follows the data, changing the axis in real time so that all of the data is shown. Below 
are the specific parts of the graph: 
Tool Bar: There are multiple things that the user can do with the graph. 

 
Resume All Tracking: The “Resume All” button -  - is grayed out while tracking.  If either axis is 

changed or the “Pause” button is pressed, this will be come green -  - Pressing “Resume All 
Tracking” will resume the tracking on the graph. 

Pause All Tracking: The “Pause” button -  - pauses the graph in its current state.  Data is still 
added, however the current X-axis and Y-axis spans no longer change.  Pressing the “Resume” 
button will continue tracking. 

Scroll Axis: This is the default way to scroll both the X and Y-axis. The “Scroll Axis” button -  - 
allows the user to scroll in both directions on the graph. 

Zoom Axis: The “Zoom Axis” button -  - allows the user to shrink or enlarge the scale of either 
axis.  By moving up or down, left or right, the span of each axis is changed. 

Zoom Out All Axis: The “Zoom Out All Axis” button -  - zooms out both the X-axis and Y-axis at 
the same time giving the user a broader look at the graph. 

Zoom In All Axis: The “Zoom In All Axis” button -  - zooms in both the X-axis and Y-axis at the 
same time giving the user view over a smaller time period. 

Zoom Box: The “Zoom Box” button -  - changes the cursor allowing the user to select a specific 
area of the graph to zoom in on for a more detailed look. 

Cursor: The “Cursor” button -  - adds a cursor to the screen that gives the coordinates of the 
graph at a certain time. Clicking and moving the cursor can give the coordinates of any point on the 
graph. See below for an example of using the “Cursor” tool: 
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Step Action 

 

Properties: The “Properties” button -  - brings up the “Properties” dialog box which gives the 
user the ability to customize the graph as desired.  Below is an example of one of the “Properties” 
tabs: 

 
 

Copy To Clipboard: The “Copy To Clipboard” button -  - copies the graph to the clipboard to 
allow the graph to be pasted into documents like a report. 

Save: The “Save” button -  - saves the graph as a “*.bmp”. 

Print: The “Print” button -  - prints the graph. 

Preview: The “Preview” button -  - gives a print preview of the graph. 
Title: The title gives the name of the parameter being trended, the units that the parameter is being 
measured in, and the date(s) of the graph, e.g. 
 

(Parameter)        (Units)    - (Date yyyy/mm/dd) 

 
 
Axis: The Y-axis is the units of the parameter.  The X-axis is the time in HH:MM:SS format. 
Redraw: Up to four parameters can be trended at the same time. By clicking the check box for a 
parameter u can show one or four at the same time for easy comparison over a period of time. 

 
Click “Redraw” and the parameters checked will be shown. 

 

6.13.4   Stop Current Trend 
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Step Action 

1 Ensure that the application is running and is connected to a device. 

 

2 Ensure that a trend is in progress.  The “Trend Activity” light at the bottom of the screen is on if a 
trend is in progress. If not then the light will be off. 

 

3 Select Trending → Stop Current Trend from the main window. 

4 You will be asked if you want to stop the current trend.  Click “Yes”.  This will stop the current trend. 

 

5 The “Trend Activity” light will now be off. 

 

 

6.14   DD Functions 

6.14.1   Adding a DD 
DevCom2000 allows the user to add a DD to the library when necessary.  Each DD must be in its appropriate 
destination for DevCom2000 to find the DD.  The format is: “C:\HCF\DDL\Library\xxxxxx\yyyy\” where “xxxxxx” 
represents the manufacturer ID and “yyyy” represents the device ID.  The user does not need to add the directory 
structure, DevCom2000 does that automatically.  To add a DD perform the following steps: 
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Step Action 

1 Ensure that the application is running, you do not have to be connected to a device to use Add DD. 

 

2 Select DD → Add DD from the main window. 

3 The Add DD dialog will open. 

 

4 Click “Browse” and go to the location of the DD that is to be added. 

5 The “DD Info” section will be populated. Confirm that it is the correct DD. Below is an example of 
0000c2/0021/0201.fm6: 

 

6 Input a “Label” for the DD if necessary. If not Click “Add DD” to add the DD to the library. 

 

6.14.2   Updating a DD Label 
DevCom2000 allows the user to add a Label for a DD if there is not one already defined.  Below is an example: 
  



 DevCom2000 User Manual 
 

 

 

 

 

 

 

 

 

 

 

 

5/1/2014 Designed and Produced under Page 63 of 71 
 ISO 9001:2008 Certification 

 
 
The manufacturer ID of Fisher Controls is 000013.  Device IDs 0002, 0004, and 0007 all do not have a label.  This is 
when updating a DD label is useful.  To update the label perform the following steps: 
 

Step Action 

1 Ensure that the application is running, you do not have to be connected to a device to use Add DD. 

 
2 Select DD → Add DD from the main window. 

3 The Add DD dialog will open. 

 
4 Click “Browse” and go to the location of the DD that is to have the label updated. 
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Step Action 

5 The “DD Info” section will be populated. Confirm that it is the correct DD. Below is an example of 
0000c2/0021/0201.fm6: 

 
6 Input a “Label” for the DD if necessary.  Click “Update Label” to update the label. 

7 Below is the new “Available DDs” sections where 000013/0002 is given the label “Updated Label”: 

 
 

6.15 HART-IP Communication 
 

Step Action 

1 Ensure that settings for HART-IP have been made in the Options- 
>Basic menu.  Note that a HART Modem is NOT required, only 
Ethernet access to the WirelessHART Gateway. 
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Step Action 

2 Click on “New Device” icon to start the connection process.  The following screen will appear. 

 

3 Click on “Quick Scan” to provide a simple list of all the devices on the WirelessHART network. Below 
is a sample screen: 
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Step Action 

4 Click on “Detailed Scan” to display all the devices as a hierarchy.  This will show what transmitters 
are connected to each WirelessHART adapter.  Note that this listing takes significantly longer to 
generate than the Quick Scan.  Below is a sample screen. 

 
 
For both types of list displays, the following icons are used: 
HART-IP Icons 

 = Gateway 

 = Adapter, WirelessHART 

 =  Transmitter 

5 Once a device list has been created, double click on the desired device to configure/review using 
DevCom2000.  Below is a sample screen: 

 



 DevCom2000 User Manual 
 

 

 

 

 

 

 

 

 

 

 

 

5/1/2014 Designed and Produced under Page 67 of 71 
 ISO 9001:2008 Certification 

Step Action 

6 To switch to a different device on the WirelessHART network: Select Window on the MENU bar, 
then click on HART-IP Device Selection to bring up the Device Menu Tree again. 
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Specifications: 
 
System Requirements (minimums) 
Operating System  Windows 32 and 64 bit versions: NT, 2000, XP, Vista, 7, 8, 8.1, and 10 
Processor Speed  Pentium, 600 MHz 
Memory   256 MB 
Hard Disk Space   500 MB 
Monitor   256-color VGA 
Communication Port USB, RS232 or Bluetooth if using a HART Modem. Wi-Fi or Ethernet for HART-IP and 

WirelessHART® 
HART Modem Not required if using HART-IP or WirelessHART®, otherwise a HART modem is 

required, e.g. 
HM-USB-ISO, HM-BT-BAT-ER, HM-RS232-ISO, or similar. 
 

Device Descriptions (DD’s) 
DD Library   Includes HART Communication Foundation’s latest release 
Generic DD   Included  
Number of devices  >1382 (call for latest information if details required) 
DD Updates Quarterly updates are sent to you automatically for 1 year. Thereafter updates are 

manually available free of charge from www.hartcomm.org 
 
Functions 
Monitor PV 
Monitor Multi-variables 
Monitor Device Status 
View and Edit Variables 
Save complete device configuration to text file and PDF file 
Write saved configurations to devices 
Sample Execute Methods: 

Trims 
    Calibrations 
    Loop Tests 
    Zero and Span 
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Appendix A 
 

Troubleshooting Guide 
For most error messages, there is a selection for “Com Troubleshooter”.  This program will guide you through the 
steps to solve your communication problems.  Below is a quick summary: 
 

Problem: Will not communicate 
 
Hardware Check: 
Verify the following 
1. Com port number on Preferences Dialog box matches HART interface hardware. 
2. Loop power supply is on. 
3. Loop resistance between 250 ohms and 1Kohms. 
4. Loop current within HART limits. 
5. If multi drop configuration, all transmitters in loop have unique addresses. 
6. HART interface hardware connected across loop resistor or across transmitter terminals. 
 
Software Check: 
Sometimes the application does not end cleanly and the communication process is still running in an unknown state. 
When this happens, it must be closed out before restarting DevCom2000. 
 
Perform the following: 
1. Close DevCom2000. 
2. Press CTRL-ALT-DEL to bring up the Windows Security Screen. 
3. Click on Task Manager. 
4. Select the Processes tab. 
5. In the list of running tasks, select HModemSvr.exe. 
6. Click on the End Process button on the dialog box. 
7. Restart DevCom2000. 
 

Problem: Get the message “Error opening COMx” 
Verify the following: 
1. Com port number on Preferences Dialog box matches HART interface hardware. 
2. HART interface hardware installed. 
  

Problem: No data in the Communication Log 
Verify the following: 
1. Verify that the “HART Activity” LED indicator on the bottom of the screen is flashing red.  If not, open a menu that 
has dynamic data that is being refreshed like PV or AO. 
2. For Windows Vista and Windows 7 users, you may need to perform the following: 

a) Open the “hosts” file using Notepad.  It is located in the following directory: 
C:\WINDOWS\system32\drivers\etc\hosts 

b) Make sure this line appears (without preceding # character) 
127.0.0.1     localhost 

c) Make sure the following line does NOT appear: 
::1   localhost 
If it is there, comment it out by placing # character in front like this: 
#::1 localhost 

d) Restart the Communication logger. 
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Note: To modify this file, you may need to perform the following in Windows: 
a) Go to Control Panel → Folder Options 
b) Select the View tab 
c) Remove the check next to Hide extensions for known file types 
d) Make the edit changes above 
e) Save the document to your documents 
f) copy the saved document to the above directory 
g) Delete the original hosts file 
h) remove the .txt extension from the new hosts file 

 
3. Turn off firewall protection temporarily to see if it is blocking the TCP/IP communications between 
DevCom2000 and the Communication Logger. 
 

Problem: The system cannot find the path specified error box 
Try the following: 
1. Verify that the device library (C:\HCF\DDL\Library) is on Drive C: 
2. If not, copy to drive C. 
 

Problem: Activation by Internet blocked by Firewall 
Try the following: 
1. Allow one time access to internet via your computer’s Firewall settings. 
2. Disable Firewall. 
3. Use manual activation method. 
  

Problem: Active Windows not shown in Windows drop down list 
Try the following: 
1. Select Window->Cascade or Window->Tile. 
2. All Windows will now be shown 
 

Problem: When using HART Server for WirelessHART in Windows 7 device selection screen doesn’t appear 
Try the following: 
1. Start Windows Explorer. 
2. Go to directory "C:\Program Files\ProComSol\Common" 
3. Run "RegisterSELECT.bat" as an Administrator 
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Appendix B 
 

Contact Information for HART Expert Ltd 
HART Expert Ltd 
125 Greenways, 
Gloucester, 
Gloucestershire, 
GL4 3SA 
United Kingdom 
 
Telephone: +44(0)7966233639 
Email: info@hart-expert.co.uk 
Web: www.hart-expert.co.uk 
 
 

Contact Information for ProComSol Ltd 
ProComSol, Ltd 
Process Communications Solutions 
13001 Athens Ave 
Suite 220 
Lakewood, OH  44107 
USA 
 
Phone: 216.221.1550 
Fax:    216.221.1554 
Email:  sales@procomsol.com support@procomsol.com 
Web:    www.procomsol.com 

mailto:info@hart-expert.co.uk
http://www.hart-expert.co.uk/

